[fxruby-users] Troubles with FXTextField encoding

Damián M. González gonzalezdamianm at hotmail.com
Thu Feb 14 11:39:40 UTC 2013

 Does anybody can help me with this? Thank you guys.
From: gonzalezdamianm at hotmail.com
To: fxruby-users at rubyforge.org; foxgui-users at lists.sourceforge.net
Subject: Troubles with FXTextField encoding
Date: Sat, 19 Jan 2013 19:00:12 -0300

 Hello Jeroen, people. I'm having troubles with the encoding. First of all, I'll tell you that in the app that am developing am using ñüáéíóú characters. I've realized that when the user write some of those characters and the app take it for work with it, later I come with troubles, that's because the string taked from the #FXTextField has ascii-8bit encoding, and as you can see here: http://www.sciencebuddies.org/science-fair-projects/project_ideas/CompSci_ASCII_Table.shtml the characters ñüáéíóú doesn't exist. So I've tried to change the encoding of the #FXTextField to UTF-8 but I didn't found the right Constant: http://rubydoc.info/gems/fxruby/frames , am I missing it? is somewhere hidding? nevermind. This is a little worse: I've tried to change the encoding as I said to another one, not UTF-8(because I didn't find it) but to CP850, so I did something like this:
#...tf = FXTextField.new(parent, 10)tf.font=(app, FXFont.new(app, "Segoe UI,90,normal,5,0,#{FONTENCODING_CP850},0"))#checking the encoding..puts tf.encoding#=> 850
 Seems to work, but it doesn't. When I enter text in the #FXTextField, press enter and ask for the encoding, ascii-8bit appears, not cp850...
tf.connect(SEL_COMMAND) do |sender, selector, data|  puts data.encoding  #=> <Encoding:ASCII-8BIT>end
 So I really don't know what happen when the user enter any of ñüáéíóú,... I'm getting strange errors when I handle those writed strings. Do any of you have some advice about this? will be thankfull to hear them. Is this a bug? Thanks for your time.
P.D.: By the way I'm using FXRuby 1.6.25, Windows 7 Proffesional 64 bits, Ruby 1.9.3p327 (2012-11-10) [i386-mingw32]. 		 	   		   		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20130214/e72cda5d/attachment.html>

More information about the fxruby-users mailing list