[fxruby-users] Bug: FXTable: programmatic deselection doesn't work as expected.

Damián M. González gonzalezdamianm at hotmail.com
Sun Dec 16 17:19:53 UTC 2012

 Hello Lars and company. Was working with FXTable wdiget; what I want to acomplish is that the the table is read only but full full read only, I mean: the user can't select any cell. Well I realized that it is not possible, so I've tried to look for another solutions, and none of them work for me. The one which put me close to the solution was: "when the user select a cell, then the robot deselect it", something like this:
table.connect(SEL_SELECTED) do |sender, selector, data|
table.getItem(data.row, data.col).selected=(false)
 Well this is curious, what happen' when you click a cell?: It becomes with a 'SelBackColor' blue, and it draw inside a kind of 'stipple': following points surrounding the inner cell. What happen when I did the previous resolution, well the 'stipple' is released, but not the blue 'SelBackColor'. So that's a partial deselection, it should also release the blue color...
I've tried also:
table.connect(SEL_SELECTED) do |sender, selector, data|
table.handle(table, SEL(SEL_DESELECTED, FXTable::ID_DESELECT_ALL), data)
neither work.. hope you can response me, thank you guys. 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20121216/53db3d08/attachment.html>

More information about the fxruby-users mailing list