[fxruby-users] Problems getting fxruby to work on Mac

dave L dglnz at yahoo.com
Thu Oct 28 02:59:32 EDT 2010


Mike unsure how much help this is so take from it what you will.

I'm running Kubuntu 10.04.

like you I had "issues" getting things to play and fit together.

from my repository manager i found a library for fox/fxruby.
then I had to be in the physical directory and run ruby fxapp.rb

Don't know if this will help the filename islibfox-16.32.2.deb so it a deb 
package, installs in with the system .SO files meaning I don't have to have 
fxruby gem installed (but in fact I have more because it works now and I an't 
going to break it).

by finding and installing that file it MAY help you get fxruby running.


Dave.





________________________________
From: Mike Falcon <mfalcon at me.com>
To: "fxruby-users at rubyforge.org" <fxruby-users at rubyforge.org>
Sent: Wed, 27 October, 2010 10:20:53 AM
Subject: [fxruby-users] Problems getting fxruby to work on Mac


Hi,
>I’m having problems with Fxruby on my Snow Leopard system.  A few months ago I 
>did a custom (a la HiveLogic) install of 1.9.1 in /usr/local.  I was working on 
>a project and at the same time trying to familiarize myself with some 1.9+ 
>changes.  I have a windows system at work(where I was primarily working on the 
>project) and usually go back and forth between my work system and my home 
>system.  I wasn’t using FXruby for this project.  I experienced no problems at 
>this point at home or work.  So I start a new project and intend to use fxruby.  
>I have the project going and decide to take it home and work on my snow leopard 
>system and it doesn’t recognize fxruby at the require line and won’t run.  It’s 
>not the project, as I just went with the ‘hello.rb’ program from Lyle’s site and 
>it doesn’t recognize fxruby either.  FXRUBY was installed with a regular 
>Rubygems install(FXRuby 1.6.20).  So I remove and re install FXruby with 
>rubygems.  Still doesn’t work.  I knew other people have had problems with 
>FXruby and custom builds on Snow Leopard so I did some googling.  I came across 
>this article by Lyle,
>http://github.com/lylejohnson/fxruby/wiki/setting-up-a-mac-os-x-build-environment-without-macports
>
>and followed the directions.  There were no problems(as long as I used the exact 
>versions Lyle suggested) with installing Fox from scratch and re-installing 
>fxruby.  Still doesn’t work.  I really want to get this running and would prefer 
>not to go back to the default ruby build.  I am using Textmate.  I had FXruby 
>running fine when I was still one Leopard.  If anybody can help it would be 
>appreciated.
>Thanks in advance,
>Mike
> 


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20101027/b568e6dc/attachment-0001.html>


More information about the fxruby-users mailing list