[fxruby-users] Ubuntu - Fxruby - require issue

Ralph Shnelvar ralphs at dos32.com
Sun Oct 3 22:09:19 EDT 2010


Mukul,



Sunday, October 3, 2010, 6:50:14 PM, you wrote:


Hi Everyone,

Just decided to play around with Fxruby and followed the installation steps found @ 

http://github.com/lylejohnson/fxruby/wiki/Setting-Up-a-Linux-Build-Environment 

Everything went alright but "require 'fox16'" fails in my script.
I have already tried running a "require 'rubygems'" before calling for "require 'fox16'". It still fails with the following error 

irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> require 'fox16'
LoadError: no such file to load -- fox16.so
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.8/gems/fxruby-1.6.20-universal-darwin-10/lib/fox16.rb:6
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:36:in `require'
from (irb):2

Any help or ideas are appreciated. Please help.

Thanks and Regards,

Mukul Sharma



I know this isn't going to help you, but I had the exact same problem under Windows and ... dammit ... I don't remember how I fixed it.

I vaguely remember having to download and install the latest version of FXRuby ... but I am not sure.  I am sorry.

I am running under Windows and this is what I have that works ....




#!/usr/bin/env ruby
@@rdebug = false
# puts $0
@@rdebug = true if $0.to_s.end_with? "rdebug"

if @@rdebug
  require 'rubygems'
  require 'ruby-debug'
  Debugger.start
end

require 'pp'      # For pretty printing

require 'ftools'  # For debugging

require 'fox16'
require "yaml"

include Fox


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20101003/9d12f516/attachment.html>


More information about the fxruby-users mailing list