[fxruby-users] Fw: Error Updating fxruby gem

Patricio Aguilera paguilera at yahoo.com
Fri Mar 26 11:46:00 EDT 2010

--- On Fri, 3/26/10, Lyle Johnson <lyle at lylejohnson.name> wrote:

> > I am running the following version:
> > ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
> Hmm. See what happens if you type this instead:
>     gem update fxruby --platform x86-mingw32
> As of FXRuby 1.6.20 I started building the Windows gems
> using the
> MinGW-based Ruby installer. Even though those are
> compatible with the
> "old" Ruby installer for Windows (which is what you're
> running), the
> platform is different ("i386-mswin32" versus
> "i386-mingw32") and that
> may be why RubyGems doesn't think it's a match...

Hi Lyle,

That appears to have done the trick:

>gem update fxruby --platform x86-mingw32
Updating installed gems
Updating fxruby
Successfully installed fxruby-1.6.20-x86-mingw32
Gems updated: fxruby
Installing ri documentation for fxruby-1.6.20-x86-mingw32...
Installing RDoc documentation for fxruby-1.6.20-x86-mingw32...

Thank you for your help.

-Thank you-



More information about the fxruby-users mailing list