[fxruby-users] Fw: Error Updating fxruby gem

Patricio Aguilera paguilera at yahoo.com
Thu Mar 25 17:15:34 EDT 2010


--- On Thu, 3/25/10, Lyle Johnson <lyle at lylejohnson.name> wrote:

> From: Lyle Johnson <lyle at lylejohnson.name>
> Patricio Aguilera <paguilera at yahoo.com>
> wrote:
> 
> >> Hello,
> >>
> >> I'm trying to run the gem update command to update
> my local
> >> gems.  When it gets to the fxruby gem, I get the
> >> following error (note: I copied the text from the
> command
> >> window):
> >>
> >> Updating fxruby
> >> Building native extensions.  This could take a
> >> while...
> >> ERROR:  Error installing fxruby:
> >>         ERROR: Failed to build gem
> >> native extension.
> 
> That's odd. It looks like you're running on Windows, so I
> don't
> understand why it didn't just select the precompiled binary
> gem for
> Windows. Which version of Ruby are you running, and from
> where did you
> download it?

I am running the following version:
ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]

I pulled it some time ago from ruby-lang.org.  I've actually been using ruby on that box for several months now and was able to install the original gem when I installed ruby after picking up the FXRuby book.  Other gems have updated correctly on that system, even when I encountered this error.

However, that particular box is running Windows XP Pro x64 Edition.

-Thank you-

Patricio


      


More information about the fxruby-users mailing list