[fxruby-users] FXRuby and 64-Bit Windows OS

Alex DeCaria Alex.Decaria at millersville.edu
Tue Mar 2 07:49:46 EST 2010

This is a follow up to my Feb 18 post on the Ruby forum:

Are others experiencing problems using FXRuby on 64-bit Windows platforms?  I have an FXRuby app that works fine on 32-bit Windows XP, but has random segmentation faults and other errors on a 64-bit Windows 7 platform.  I've attached a screen shot of the typical errors that I get.  The application will run for a time, but eventually will crash with a segmentation fault.

Also, there are numerous FXCursor.cpp errors that appear as the application is starting (but the application still starts and runs despite these initial errors).

Again, this only happens on the 64-bit system.  The same app works with no errors on a 32-bit Windows OS.

Lyle had responded to my earlier post indicating that it seems to be an issue with the FOX Library itself, not the FXRuby wrapper.  I see on the FOX Library webpage that over the past year or two they've addressed some 64 vs 32 bit issues.  Does FXRuby use the latest version of the FOX library?  If not, will the newer version of the FOX Library solve these issues?  Are there any workarounds?

--Alex DeCaria

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20100302/6d960234/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Error.jpg
Type: image/pjpeg
Size: 296421 bytes
Desc: Error.jpg
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20100302/6d960234/attachment-0001.bin>

More information about the fxruby-users mailing list