[fxruby-users] FxRuby 1.9 Binary Gem?

CCdrom at web.de CCdrom at web.de
Sun Sep 27 20:40:56 EDT 2009


I am a beginner to Ruby but i like it very much. After installing the One-Click-Installer Version 1.8.6 i was very happy- everything worked finde. But i had update to version ruby 1.9.1p243 (2009-07-16 revision 24175) [i386-mingw32] because of Look-Behinds in Regular Expressions.

But now the FxRuby Gem installed just fine but doesn't work anymore- I got an error, that msvcrt-ruby18.dll is missing (the old one from ruby 1.86 doesn't work). After searching the Internet i know why: FxRuby's Source is compatible to 1.9 but the binaries are for the one-click-installer Version. So the howto mean's i have to compile Ruby and FxRuby ... As a beginner this is a lot of confusing- I get some errors and i don't know which version of visual c++ i should use and so on. On the other side I shouldn't use the mswin32 version of ruby, because it's changing to mingw32. Here i also get a lot of errors installing and try compiling with MSYS, MGWIN.

For WxRuby there is a special 1.9 gem available- works fine. But i want to use FxRuby. Is there a way to get a FxRuby 1.9 Binary Gem for Windows? Don't get me wrong, but i spend hours of searching informations about these problems- that's not the Ruby Way, especially for a beginner it's very confusing and time intensive. A FxRuby 1.9 binary gem would be perfect.

Thanks in advance,

More information about the fxruby-users mailing list