[fxruby-users] FxRuby failing on Ruby 1.9.1 windows

Lyle Johnson lyle at lylejohnson.name
Mon May 18 11:47:26 EDT 2009


On May 17, 2009, at 12:40 PM, Janos Sebok wrote:

> Hi all.
>
> I am new to FxRuby, and trying to install the toolkit.
>
> I'm running winXP
> >ruby -v
> ruby 1.9.1p0 (2009-01-30 revision 21907) [i386-mswin32]
>
> >gem -v
> 1.3.3
>
> >gem list
>
> *** LOCAL GEMS ***
>
> fxruby (1.6.19)
> rubygems-update (1.3.3)
>
> ---
> My problem is: require 'fox16' fails with a OS error message  
> complaining
> "Can not start application because msvcrt-ruby18.dll is not found".  
> After closing the error window the console reads:
>
> >ruby test.rb
> test.rb:2:in `require': 126: A megadott modul nem talalhato(which  
> means module not found).   - d:/Ruby/Vm/1.9.1-p0/lib/ruby/gems/1.9.1/ 
> gems/fxruby-1.6
> .19-x86-mswin32-60/ext/fox16/fox16.so (LoadError)
>         from test.rb:2:in `<main>'
>
> fox16.so is right where it is looked for, but it is linking to  
> msvcrt-ruby18.dll.
> Of course the 1.8 dll is not present. What may cause this? I  
> remember to have read FxRuby is Ruby 1.9 compatible for a while.

The FXRuby source code is compatible with Ruby 1.9; it can be compiled  
for use with Ruby 1.9.

The FXRuby binary gem for Windows is built for use with the One-Click  
Installer for Ruby (on Windows), which is based on Ruby 1.8.6. If you  
need a version of FXRuby that works with your Ruby 1.9 on Windows,  
you'll need to compile it yourself (or get someone else to).

> The very same gem works just fine on Ruby 1.8.7-p72.

Yes, this is not too surprising, since there were few ABI changes  
between Ruby 1.8.6 and Ruby 1.8.7.


More information about the fxruby-users mailing list