[fxruby-users] fxruby 1.6.19 gem fails to find appropriate libpng library under Mac OS X 10.4.11

Lyle Johnson lyle at lylejohnson.name
Thu May 14 12:13:48 EDT 2009


On May 11, 2009, at 6:07 PM, Ronald D. Mabbitt wrote:

> I was curious -- is there a known issue with trying to use fxruby  
> gems under Mac OS X 10.4.11?  After installing fxruby-1.6.19 via gem  
> under ruby 1.8.6, I'm getting load errors indicating that fxruby is  
> looking for the libpng library in /usr/X11/lib, when in fact Mac OS  
> X 10.4.11 doesn't even HAVE a /usr/X11/lib (only a /usr/X11R6/lib).   
> The place it should find the file is /sw/lib/, as I'm using Fink,  
> and /sw/lib is certainly in my PATH and LIBPATH variables.  Here is  
> the actual error message:

<snip>

The FXRuby binary gem for OS X is built on my MacBook, which is  
running Leopard (10.5.x). So it's based on the Ruby that comes  
preinstalled with Leopard, and the X server that ships with that OS  
version, etc. So yes, you're going to need to either build it from  
source (with help from Fink for some of the dependencies).

Hope this helps,

Lyle


More information about the fxruby-users mailing list