[fxruby-users] FXRuby Installation failing

Lyle Johnson lyle at lylejohnson.name
Sun Jun 7 16:30:13 EDT 2009

On Jun 5, 2009, at 11:23 PM, Nataraj S Narayan wrote:

> Which is the most stable version of FXRuby that can be used with ruby
> 1.8.7 (2008-05-31 patchlevel 0)?

FXRuby should be compatible (which is to say, compileable-against) any  
release of Ruby 1.8 or 1.9. I'm running Ruby 1.8.6-p368, but Ruby  
1.8.7-p0 should *probably* work too.

> I am having lots of trouble installing fxruby using gem.
> root at at91sam9263ek:~$ gem install fxruby-1.6.19.gem
> Building native extensions.  This could take a while...
> ERROR:  Error installing fxruby-1.6.19.gem:
>        ERROR: Failed to build gem native extension.
> /usr/local/bin/ruby extconf.rb
> Gem files will remain installed in
> /usr/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19 for inspection.
> Results logged to
> /usr/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19/ext/fox16/gem_make.out
> root at at91sam9263ek:~$ cat
> /usr/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19/ext/fox16/gem_make.out
> /usr/local/bin/ruby extconf.rb

So what are the contents of this file:


or is it empty?

> The foxlib example program 'Calculator' works well. Using
> libFOX-1.6.so.0.0.36. But fxruby install doesnt finish.

OK, but I'll need some information other than "it doesn't build" to  
figure out what's going on. The gem_make.out file should tell us that.

> During my previous install on I used libFOX-1.6.so.0.0.34. Could it be
> any bug in ibFOX-1.6.so.0.0.36?


> Trying out a source install now.

OK, if that doesn't work either, please send me the gem_make.out file  
from your failed gem installation.



More information about the fxruby-users mailing list