[fxruby-users] FXRuby Installation failing

Nataraj S Narayan natarajsn at gmail.com
Sat Jun 6 00:23:39 EDT 2009


Which is the most stable version of FXRuby that can be used with ruby
1.8.7 (2008-05-31 patchlevel 0)?

I am having lots of trouble installing fxruby using gem.

root at at91sam9263ek:~$ gem install fxruby-1.6.19.gem
Building native extensions.  This could take a while...
ERROR:  Error installing fxruby-1.6.19.gem:
        ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb

Gem files will remain installed in
/usr/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19 for inspection.
Results logged to

root at at91sam9263ek:~$ cat
/usr/local/bin/ruby extconf.rb

The foxlib example program 'Calculator' works well. Using
libFOX-1.6.so.0.0.36. But fxruby install doesnt finish.

During my previous install on I used libFOX-1.6.so.0.0.34. Could it be
any bug in ibFOX-1.6.so.0.0.36?

Trying out a source install now.

Please help me.



More information about the fxruby-users mailing list