[fxruby-users] foxGUIb - believe it's intalled okay but....

dave L dglnz at yahoo.com
Tue Jan 27 04:36:47 EST 2009


Hi Henon & Michèle,

Sorry but i've physically gone to the /usr/bin directory and ran the command with no joy!!!

here is what i've got.

dave at AMD3000:/usr/bin$ ruby foxGUIb.rb
ruby: Permission denied -- foxGUIb.rb (LoadError)
dave at AMD3000:/usr/bin$ sudo ruby foxGUIb.rb
sudo: unable to resolve host AMD3000
foxGUIb.rb:7:in `require': no such file to load -- version (LoadError)
        from foxGUIb.rb:7
dave at AMD3000:/usr/bin$ 

now i've actually got the sample programs working by going into the directory
/spare/downloads/FXRuby.../examples/ruby <an example script> and it's worked so i know i've got FXRuby installed okay or would it be Fox making it work?

Could a ruby gem cause any issues?
I did try and install a FXGem before getting FXRuby going

this is what i got when last i tried to install FXRuby and so believe it installed correctly!
***** line below is start of the terminal screen grab *****
install timeout.rb /usr/local/lib/site_ruby/1.8/fox16
install undolist.rb /usr/local/lib/site_ruby/1.8/fox16
install version.rb /usr/local/lib/site_ruby/1.8/fox16
<--- lib/fox16
<--- lib
---> ext
---> ext/fox16
mkdir -p /usr/local/lib/site_ruby/1.8/i486-linux/.
install fox16.so /usr/local/lib/site_ruby/1.8/i486-linux/.
---> ext/fox16/include
<--- ext/fox16/include
<--- ext/fox16
<--- ext
dave at AMD3000:/spare/downloads/FXRuby-1.6.18$

***** end of the terminal screen grab *****



________________________________
From: Meinrad Recheis <meinrad.recheis at gmail.com>
To: fxruby-users at rubyforge.org
Sent: Tuesday, 27 January, 2009 10:04:20 PM
Subject: Re: [fxruby-users] foxGUIb - believe it's intalled okay but....


On Tue, Jan 27, 2009 at 9:19 AM, dave L <dglnz at yahoo.com> wrote:

I've tried calling foxGUIb from command line as ...

ruby foxGUIb.rb got an error - no file found by that name

ruby /usr/bin/foxGUIb.rb again got error to say i didn't have permissions

sudo ruby /usr/foxGUIb.rb and got informed ....
/usr/bin/foxGUIb.rb:7:in `require': no such file to load -- version (LoadError)
        from /usr/bin/foxGUIb.rb:7

Now do i need to add anything into ruby's configuration (ie have a path pointing to anything?)
Line 7 say require "Version"

i have fox1.6 installed!

many thanks.

dave.

yes, you need to call it from the directory where foxguib.rb is located. i'm sure there is a quite easy way to get around this limitation. so if anyone cares to fix it i'd be glad to merge it in. btw.: for everyone who loves git, there is now a foxguib repo at github:  git://github.com/henon/foxguib.git
-- henon


      Get the world&#39;s best email - http://nz.mail.yahoo.com/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20090127/7f842943/attachment.html>


More information about the fxruby-users mailing list