[fxruby-users] foxGUIb - believe it's intalled okay but....

Meinrad Recheis meinrad.recheis at gmail.com
Tue Jan 27 04:04:20 EST 2009


On Tue, Jan 27, 2009 at 9:19 AM, dave L <dglnz at yahoo.com> wrote:

> I've tried calling foxGUIb from command line as ...
>
> ruby foxGUIb.rb got an error - no file found by that name
>
> ruby /usr/bin/foxGUIb.rb again got error to say i didn't have permissions
>
> sudo ruby /usr/foxGUIb.rb and got informed ....
> /usr/bin/foxGUIb.rb:7:in `require': no such file to load -- version
> (LoadError)
>         from /usr/bin/foxGUIb.rb:7
>
> Now do i need to add anything into ruby's configuration (ie have a path
> pointing to anything?)
> Line 7 say require "Version"
>
> i have fox1.6 installed!
>
> many thanks.
>
> dave.
>

yes, you need to call it from the directory where foxguib.rb is located. i'm
sure there is a quite easy way to get around this limitation. so if anyone
cares to fix it i'd be glad to merge it in. btw.: for everyone who loves
git, there is now a foxguib repo at github:  git://
github.com/henon/foxguib.git
-- henon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20090127/93d49ee6/attachment.html>


More information about the fxruby-users mailing list