[fxruby-users] foxGUIb - believe it's intalled okay but....

Michèle Garoche migatine at gmail.com
Tue Jan 27 03:54:11 EST 2009


Le 27 janv. 2009 à 09:19, dave L a écrit :

> I've tried calling foxGUIb from command line as ...
>
> ruby foxGUIb.rb got an error - no file found by that name
>
> ruby /usr/bin/foxGUIb.rb again got error to say i didn't have  
> permissions
>
> sudo ruby /usr/foxGUIb.rb and got informed ....
> /usr/bin/foxGUIb.rb:7:in `require': no such file to load -- version  
> (LoadError)
>         from /usr/bin/foxGUIb.rb:7
>
> Now do i need to add anything into ruby's configuration (ie have a  
> path pointing to anything?)
> Line 7 say require "Version"
>
> i have fox1.6 installed!
>
> many thanks.
Not sure if it will be useful to you, but here's how I call foxGuib:

I've the source in /usr/local/src, so, once it is compiled and  
installed, I jump into it:

cd /usr/local/src/foxGUIb_1.0.0/foxGUIb

and call it for this directory (I've read somewhere that you should  
be in this directory to call it);

ruby foxGUI.rb

Of course X11 should be open beforehand (if you're on a Mac), then  
after some time, you'll see the edi and can work with it.



Cheers,
Michèle
<http://micmacfr.homeunix.org>



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20090127/49daf74a/attachment.html>


More information about the fxruby-users mailing list