[fxruby-users] (no subject)

James Hibbard mr_nice66 at yahoo.com
Sat Jan 24 07:26:21 EST 2009


Hi,

I wrote a GUI using FXRuby under WinXP.
I then upgraded to Vista, installed Ruby (and thus by default FXRuby) and ran my GUI.
It was then that I noticed that the colours have gone weird. 
The
main user interface is now white (the default colour that Vista uses),
but all of the data targets and tables have remained beige (RGB 236,
233, 216).
Of course one can individualy declare a white background
colour for each of these widgets, but then it looks garish if run on XP
or Linux.
I'm looking for a setting I can apply to make the colour for the application uniform and overide the system default.
I already tried such things as app.backColour = FXRGB(236, 233, 216).
In an earlier post it was suggested that I could change these settings by running FOX ControlPanel application.
Unfortunately I have no idea how to do this and extensive Googling has yielded no results.

I would be grateful for any help you could give.
I have included a screenshot to highlight my problem.


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20090124/d8cd0a0e/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vista_colours.jpg
Type: image/jpeg
Size: 63272 bytes
Desc: not available
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20090124/d8cd0a0e/attachment-0001.jpg>


More information about the fxruby-users mailing list