[fxruby-users] fxRuby not Installing

David MacMahon davidm at astro.berkeley.edu
Tue Jan 20 00:07:53 EST 2009


Maybe stuff left around from a previously failed fxruby build attempt  
is confusing things?  You could try this...

sudo gem uninstall fxruby
sudo gem install fxruby

Can you run any Fox programs that use fxscintilla?

Dave

On Jan 19, 2009, at 20:50 , justin shell wrote:

> Added Xft2 and that got fox and fxscintilla installed via macports.  
> Thanks for the tip, David.
>
> However, fxruby is still not installing. I'm installing via the gem  
> command. The last three lines of the error report read:
>
> /usr/bin/ld: can't locate file for: -lfxscintilla
> collect2: ld returned 1 exit status
> make: *** [fox16.bundle] Error 1
>
> I can forward the full error if that would help.
>
> I'm not sure why it cannot locate the file. I've confirmed  
> fxscintilla is installed and active by using "port installed".  
> Anything else I should be looking for? Should I reinstall  
> fxscintilla. Could it be something in my.bash_login file? I'm going  
> back to the documentation to see if I've missed something, but any  
> advice is welcome.
>
> Thanks,
> Justin
>
>
> On Mon, Jan 19, 2009 at 6:11 PM, David MacMahon  
> <davidm at astro.berkeley.edu> wrote:
>
> On Jan 19, 2009, at 14:53 , Lyle Johnson wrote:
>
> On Jan 19, 2009, at 4:40 PM, Justin Shell wrote:
>
> I then opened up MacPorts and tried installing Fox that way. I got  
> some errors related to fonts (there were a lot of them so I didn't  
> paste them) and Fox was not installed.
>
> That's odd. Are you using MacPorts 1.7.0 (the current release)? I  
> haven't had any (recent) reports about the FOX port not building  
> properly. It would be good if you could file a bug report at  
> MacPorts.org on that one.
>
> I don't know if this is related, but I also had problems installing  
> Fox via MacPorts on Tiger (Mac OS X 10.4.11) until I found this...
>
> http://trac.macports.org/ticket/17779
>
> Apparently, the Fox port lists Xft2 as a library dependency, but  
> Tiger's "built-in" Xft2 library is not adequate so Fox on Tiger via  
> MacPorts really needs the Macports Xft2 port installed.
>
> My symptom was that things would build, but the Fox examples (e.g.  
> calculator) would crash during startup somewhere in the fontconfig  
> library, so it looks like it might be a different problem from  
> yours, Justin, but if you're on Tiger you could try doing...
>
> sudo port install Xft2
> sudo port install fox
> sudo gem install fox16
>
> Hope this helps,
> Dave
>
>



More information about the fxruby-users mailing list