[fxruby-users] Vista issues

James Hibbard mr_nice66 at yahoo.com
Fri Jan 16 03:34:07 EST 2009


Thanks for the reply Jeroen,

>You should be able to run the FOX ControlPanel application and change color schemes; normally,
>FOX fishes its colors from the Windows GUI control registry; this works pretty good on 2K and XP.

It's probably a silly question, but how can I access the FOX ControlPanel application?
I tried Googling and consulting the PP FXRuby book, but couldn't find anything.

>I don't know what's up with the shutter under Vista.  I can't say I have any idea why you're
>seeing this, since its supposed to do all the timing completely inside FOX.

I would have thought so too.

>I'm not sure if you're able to research this issue or not;
>I'd like to fix it if other people experience this also.

Certainly willing if not able. If you can give me any pointers as to what I could do to research it, I will do so.
We have a couple of machines running Vista at work, so I could try and recreate the situation there.

Cheers
Jim




________________________________
From: Jeroen van der Zijp <jeroen at fox-toolkit.org>
To: fxruby-users at rubyforge.org
Sent: Friday, 16 January, 2009 0:01:32
Subject: Re: [fxruby-users] Vista issues

On Thursday 15 January 2009, James Hibbard wrote:
> Hi,
> 
> I wrote a GUI using FXRuby under WinXP.
> I then upgraded to Vista, installed Ruby (and thus by default FXRuby) and ran my GUI.
> It was then that I noticed that the colours have gone weird. 
> The main user interface is now white (the default colour that Vista uses), but all of the data targets and tables have remained beige (RGB 236, 233, 216).
> Of course one can individualy declare a white background colour for each of these widgets, but then it looks garish if run on XP or Linux.
> Is there any setting I can apply to make the colour for the application uniform and overide the system default.
> I already tried such things as app.backColour = FXRGB(236, 233, 216).
> 

You should be able to run the FOX ControlPanel application and change color schemes; normally,
FOX fishes its colors from the Windows GUI control registry; this works pretty good on 2K and XP.

I don't have Vista myself so I never noticed the problem.

> I also noticed that the FXShutter doesn't work properly under Vista. When you click on the various shutter items, it just flicks from one item to the next without the smooth animation in between.
> It just flicks from one shutter button to the next in one frame.
> Is there any way of fixing this, or should I just can Vista and go back to XP.

I don't know what's up with the shutter under Vista.  I can't say I have any idea why you're
seeing this, since its supposed to do all the timing completely inside FOX.

I'm not sure if you're able to research this issue or not; I'd like to fix it if other 
people experience this also.



        - Jeroen


_______________________________________________
fxruby-users mailing list
fxruby-users at rubyforge.org
http://rubyforge.org/mailman/listinfo/fxruby-users



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20090116/15d80293/attachment-0001.html>


More information about the fxruby-users mailing list