[fxruby-users] Error installing MacPorts rb-fxruby...

Rob McCabe rob.mccabe at gmail.com
Sat Feb 7 13:38:55 EST 2009


Hi all,

I'm encountering an error while trying to install the MacPorts version of
fxruby on a Intel Mac running 10.4.11.  It appears to be having trouble
installing and building the 'fox' library prerequisite.  It looks like  it's
having trouble generating the libraries: "-o .libs/libFOX-1.6.0.0.34.dylib"
and "-o libFOX-1.6.la".  The errors generated are:

/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: can't locate file for:
-lGLU
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: file: -lGLU is not an
object file (not allowed in a library)
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: can't locate file for:
-lGL
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: file: -lGL is not an
object file (not allowed in a library)

My understanding is  that GLU and GL are OpenGL libs  and should just "be
there" with the OS, right?

The version of  fox it's trying to install is 1.6.34.  My version of
MacPorts is 1.70...  I had just completely uninstalled my previous version
and installed 1.70 from scratch.  I've tried "port clean" on the fox and
Xft2 packages and tried the install again, with no luck.

I poked around in /usr/lib but did not see libs named "*GL*"... any idea
where these should be hanging out?  Any other suggestions?

Thanks in advance!

Rob
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20090207/d6875e8b/attachment.html>


More information about the fxruby-users mailing list