[fxruby-users] Install question on Mac

Pito Salas rps at salas.com
Tue Apr 28 10:53:15 EDT 2009


Hi all,

This question has come through before, but I can't come up with a
solution based on reading many threads etc so please bear with me with
a simple question. I am on Mac, and manage my installs via port and
gems. Here's the state of things:

... I seem to have Fox itself properly installed:

$ port info foxfox @1.6.34, Revision 1 (x11)
Variants:    universal

FOX is a C++ based Toolkit for developing Graphical User Interfaces
easily and effectively.
Homepage:    http://www.fox-toolkit.org/

Build Dependencies:   pkgconfig
Library Dependencies: tiff, libpng, jpeg, xorg-libXcursor, Xft2,
xorg-libXrandr, freetype
Platforms:            darwin
Maintainers:          lyle at lylejohnson.name

... I also seem to have the gem properly installed:

$gem list fxruby

*** LOCAL GEMS ***

fxruby (1.6.19)
$

... and yet when I run this hello world example:

require 'fox16'
include Fox
theApp = FXApp.new
theMainWindow = FXMainWindow.new(theApp, "Hello")
theApp.create
theMainWindow.show
theApp.run

... I get this obnoxious error

$ ruby play1.rb
/opt/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19-universal-darwin-9/ext/fox16/fox16.bundle:
dlopen(/opt/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19-universal-darwin-9/ext/fox16/fox16.bundle,
9): Library not loaded:
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/libruby.1.dylib
(LoadError)
  Referenced from:
/opt/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19-universal-darwin-9/ext/fox16/fox16.bundle
  Reason: image not found -
/opt/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19-universal-darwin-9/ext/fox16/fox16.bundle
	from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
	from play1.rb:1
$

QUESTIONS:

- can anyone see what's wrong?
- is the fact that the port install of Fox says "X11" mean that
there's no native mac binding for fox?

Thanks!!

Pito


More information about the fxruby-users mailing list