[fxruby-users] problem with fox instalation

angico angico at angico.org
Thu Jul 31 10:56:11 EDT 2008


Em Qui, 2008-07-31 às 08:27 -0500, Lyle Johnson escreveu:
> On Jul 31, 2008, at 4:52 AM, angico wrote:
> 
> > I guess I found the problem. It was a matter of conflicting versions  
> > of
> > installed gems. As I initially stated I had
> > fxruby-1.6.16-universal-darwin-9 and fxruby-1.6.15-universal-darwin-9
> > installed on the laptop...
> 
> Those gems are for OS X, not Ubuntu. They definitely shouldn't work on  
> your Linux notebook!
> 
> > So I just removed both, and ran sudo gem
> > install fxruby again, this time selecting 'fxruby 1.6.16 (ruby)' from
> > the installation options, and now it works just fine.
> 
> Great!
> _______________________________________________
> fxruby-users mailing list
> fxruby-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/fxruby-users

Thanks, Lyle. Anyway, I think it's a little hard for newbies like me to
find out what those options really mean, since they don't say much about
it. For instance:

$ sudo gem install mysql
Need to update 1 gems from http://gems.rubyforge.org
.
complete
Select which gem to install for your platform (x86_64-linux)
 1. mysql 2.7.3 (mswin32)
 2. mysql 2.7.1 (mswin32)
 3. mysql 2.7 (ruby)
 4. mysql 2.6 (ruby)
 5. Skip this gem
 6. Cancel installation
> 

Which option should I choose? I bet it's 3, but it's really not clear at
all.

Regards,

-- 
angico
------
home page: www.angico.org
Gnu/Linux, FLOSS, Espiritismo, e eu por mim mesmo 8^I
------
contatos:
email: angico at angico.org
skype: angico00
------



More information about the fxruby-users mailing list