[fxruby-users] problem

Lyle Johnson lyle at lylejohnson.name
Mon Jul 14 22:12:26 EDT 2008


On Jul 14, 2008, at 9:20 AM, Lyle Johnson wrote:

> Whoops. Looks like I've made a mistake in building the OS X gem for  
> FXRuby 1.6.16. I will take a look at this tonight and try to get an  
> updated gem out ASAP. Basically, it has linked to the shared library  
> for FOX (which you don't have) when it should have been linked to  
> the static library for FOX.

OK. I've re-uploaded the gem for FXRuby 1.6.16 on OS X and it should  
(I guess?) propagate out to the mirrors over the next few hours.  
You'll presumably need to do a "gem uninstall fxruby", then try the  
install again (not sure whether RubyGems will try to cache the old  
version or not).

---
"FXRuby: Create Lean and Mean GUIs with Ruby"
Now available from the Pragmatic Bookshelf!
http://www.pragprog.com/titles/fxruby







More information about the fxruby-users mailing list