[fxruby-users] problem

Lyle Johnson lyle at lylejohnson.name
Mon Jul 14 10:20:20 EDT 2008


On Jul 12, 2008, at 10:23 AM, Fred Horton wrote:

> Hi -- I just got your book FXRuby and am trying to get it working on  
> Leopard -- I had no problems getting it to work on Vista or Ubuntu  
> but when I tried to follow the post on your blog for Leopard I got  
> the following error -- I don't know enough about Leopard or Ruby for  
> that matter to troubleshoot this myself so I was hoping someone may  
> have run into this before and can offer a solution.  Here is a  
> printout of what I see:

<snip>

Whoops. Looks like I've made a mistake in building the OS X gem for  
FXRuby 1.6.16. I will take a look at this tonight and try to get an  
updated gem out ASAP. Basically, it has linked to the shared library  
for FOX (which you don't have) when it should have been linked to the  
static library for FOX.

---
"FXRuby: Create Lean and Mean GUIs with Ruby"
Now available from the Pragmatic Bookshelf!
http://www.pragprog.com/titles/fxruby







More information about the fxruby-users mailing list