[fxruby-users] Custom SplashScreen. Seg fault when wrapped in a class

Andreas S andreas_s at hotmail.com
Fri Dec 5 02:54:09 EST 2008


1.9? That's interesting. Actually I wanted to try 1.9 to speed things up a little bit, but didn't know
fxruby already supports 1.9.

I just tried to install it with the latest 1.9.1-preview2, but it won't build. Something with 'len' is not a
member of RArray struct anymore. 'len' is a union member now in 1.9. I regret that my C is not good enough to understand whether this is the problem or not.

Just FYI.
-andre

From: lyle at lylejohnson.name
To: fxruby-users at rubyforge.org
Date: Thu, 4 Dec 2008 18:36:56 -0600
Subject: Re: [fxruby-users] Custom SplashScreen. Seg fault when wrapped in a	class

Actually, I was running it with Ruby 1.9.1. I will try again tomorrow with 1.8.7, but I'd recommend sticking with 1.8.6.
Hope this helps,
Lyle

On Dec 4, 2008, at 3:48 PM, Andreas S <andreas_s at hotmail.com> wrote:


Hi Lyle,

 

Thanks for looking at this. I forgot to mention that I was using ruby 1.8.7-p72 (also tried 1.8.7-p22). Since you didn't have the problem, I re-installed 1.8.6+p114 and tried again. Everything went smoothly. I can only conclude the problem is with ruby 1.8.7. Did you try it with 1.8.6? 

 

I'm jumping ahead here, but suppose that is the case, then herewith I'm reporting fxruby seg-faulting with ruby 1.8.7.

 

I'm not sure how important this case is for you to spend time on it. For now I can go back and use 1.8.6 to avoid this problem. 

 

Thanks again, Lyle

-andre

Suspicious message? There’s an alert for that.  Get your Hotmail® account now.
_______________________________________________
fxruby-users mailing list
fxruby-users at rubyforge.org
http://rubyforge.org/mailman/listinfo/fxruby-users
_________________________________________________________________
Send e-mail anywhere. No map, no compass.
http://windowslive.com/Explore/hotmail?ocid=TXT_TAGLM_WL_hotmail_acq_anywhere_122008
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20081205/dc7a735e/attachment-0001.html>


More information about the fxruby-users mailing list