[fxruby-users] fxruby gem install problem

Lyle Johnson lyle at lylejohnson.name
Tue Apr 15 08:24:20 EDT 2008

On Apr 14, 2008, at 10:45 PM, Tom Cloyd wrote:

> I can report a success!

Great! Thanks for sticking with it!

> Can I assist "the cause" by reporting this issue somewhere? I looked a
> bit for some obvious place, and didn't see it, but then there's a  
> lot I
> don't know, so I may have overlooked something pretty obvious.

I guess the first question to ask is whether apt-get is even supposed  
to automatically install dependencies for a package. Surely it is?  
Most package managers work that way, but maybe APT doesn't.

Assuming it *was* supposed to have installed the dependencies for  
libfox-1.6-dev at the same time that you installed that package, I  
guess the next step would be to try to get in touch with the  
maintainer of that package (again, if Ubuntu/Debian has the idea of  
package-specific maintainers). This problem that you've run into isn't  
a problem with FOX per se --- it's an issue with how that particular  
deb package is constructed. Again, I'm being vague simply because I  
don't have much experience with Ubuntu and Debian.

Hope this helps,


More information about the fxruby-users mailing list