[fxruby-users] persistent problem installing foxGUIb

Meinrad Recheis meinrad.recheis at gmail.com
Tue Apr 15 06:56:24 EDT 2008


On Tue, Apr 15, 2008 at 12:48 PM, Meinrad Recheis <meinrad.recheis at gmail.com>
wrote:

> On Tue, Apr 15, 2008 at 6:24 AM, Tom Cloyd <tomcloyd at comcast.net> wrote:
>
> > Tom Cloyd wrote:
> > > Since I just apparently successfully installed fxruby, I'm surprised
> > to
> > > see that I still cannot get foxGUIb to run.
> > >
> > > "...Successfully installed fxruby-1.6.14
> > > Installing ri documentation for fxruby-1.6.14...
> > > Installing RDoc documentation for fxruby-1.6.14..."
> > >
> > > tom at tomcloyd-desktop:~/programs/foxGUIb_0.7.1/libGUIb$ cd
> > > '/home/tom/programs/foxGUIb_0.7.1/libGUIb'
> > > tom at tomcloyd-desktop:~/programs/foxGUIb_0.7.1/libGUIb$ sudo ruby
> > install.rb
> > > ...
> > > parsearg_config
> > > install.rb: entering config phase...
> > > ---> lib
> > > <--- lib
> > > install.rb: config done.
> > > parsearg_setup
> > > install.rb: entering setup phase...
> > > ---> lib
> > > <--- lib
> > > install.rb: setup done.
> > > parsearg_install
> > > parsearg_install!!! ARGV:
> > > install.rb: entering install phase...
> > > ---> lib
> > > mkdir -p /usr/local/lib/site_ruby/1.8/
> > > install libGUIb14.rb /usr/local/lib/site_ruby/1.8/
> > > install libGUIb16.rb /usr/local/lib/site_ruby/1.8/
> > > <--- lib
> > > install.rb: install done.
> > > tom at tomcloyd-desktop:~/programs/foxGUIb_0.7.1/libGUIb$ cd
> > > '/home/tom/programs/foxGUIb_0.7.1/foxGUIb'
> > > tom at tomcloyd-desktop:~/programs/foxGUIb_0.7.1/foxGUIb$ ruby foxGUIb.rb
> > > please install libGUIb!!
> > > no such file to load -- fox16
> > >
> > > I have NO idea what the problem is here (as usual). Any help would be
> > > appreciated.
> > >
> > > Thanks!
> > >
> > > T.
> > >
> > >
> > Sorry - I should have mentioned - I'm doing all this on Kubuntu Linux
> > 7.10.
> >
> > - t.
>
>
> Ok. libguib is trying to load fox16 by executing the line
> require "fox16"
> which yields the error you are seeing. you can test if fxruby works by
> using irb. it should look like this:
>
> irb(main):001:0> require "fox16"
> => true
> irb(main):002:0> Fox.fxrubyversion
> => "1.6.6"
> irb(main):003:0>
>
> Can you post the complete error message from the foxguib.log file?
> -- henon
>
> PS: I remember now, you need to require rubygems to be able to load gems.
I think the following might work for you:

ruby -rubygems foxguib.rb

or setting the environment variable RUBYOPT to -rubygems
hth,
-- henon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/fxruby-users/attachments/20080415/b4794108/attachment-0001.html 


More information about the fxruby-users mailing list