[fxruby-users] fxruby gem install problem

Lyle Johnson lyle at lylejohnson.name
Sun Apr 13 16:07:35 EDT 2008


On Apr 13, 2008, at 5:06 AM, Tom Cloyd wrote:

> I've installed libfox-1.6-dev, and after that attempted install of
> fxruby, with this result:
>
> $ sudo gem install fxruby

<snip>

> /usr/bin/ld: cannot find -lXrandr
> collect2: ld returned 1 exit status
> make: *** [fox16.so] Error 1

OK, so it looks like the libfox-1.6-dev package depends on something  
called libXrandr.so, which I know is one of the X windows extension  
libraries. I don't know why the person who built the FOX package for  
Ubuntu wouldn't have made that an automatically-included dependency,  
but then again I don't really use Ubuntu on a regular basis.

At any rate, it looks like you need to install that library as well to  
get FXRuby to build. When I google for "ubuntu xrandr", I get some  
hits for the package name "xrandr", so I guess that's what you want  
(not sure):

	sudo apt-get install xrandr

If anyone else reading is more up-to-speed on Ubuntu, please chime in  
with the correct incantation!

Hope this helps,

Lyle


More information about the fxruby-users mailing list