[fxruby-users] FXRuby help needed

Lyle Johnson lyle.johnson at gmail.com
Mon May 14 12:01:17 EDT 2007

On 5/14/07, kloftaj at muohio.edu <kloftaj at muohio.edu> wrote:

> I recently downloaded the FXRuby package, but I cannot get it to work when
> I try to apply it to a Ruby class.
> The lines:
> "require 'fox16'"
> "include Fox"
> are not working for me.  The error I receive is:
> window.rb:1:in `require': No such file to load --
> /root/Desktop/tomove/ForRuby/lib/fox16 (LoadError)
>         from window.rb:1
> Do I need to put those folders within a certain eclipse folder?  Right now
> I have a set up of:
> where Eclipse is being stored
> /opt/eclipse 3.2/
> /root/Desktop/tomove/ForRuby/lib/fox16
> Do I need to add fox16 to an eclipse plugin folder?


I don't quite know how to answer your question, because I'm confused
about what Eclipse has to do with any of this.

Let's start with some basic information:

When you say you downloaded the "FXRuby package", what do you mean?
What was the name of the file, and where did you get it? Did you
follow the installation instructions found in the Users' Guide?


What operating system are you using, and which version of Ruby? And
what does Eclipse have to do with any of this?



More information about the fxruby-users mailing list