[fxruby-users] Text input issues...

gga ggarra at advancedsl.com.ar
Fri Mar 23 15:53:32 EDT 2007


Lyle Johnson wrote:
> On 3/8/07, gga <ggarra at advancedsl.com.ar> wrote:
> 
>> I run into an issue with latest FXRuby1.6 under linux.
>> Basically, the problem was that its text widgets have suddenly stopped
>> working (even fxruby demos).  They would not take any keys that were
>> typed in.
>> All other applications worked fine.
>> Any ideas what could have triggered this?
> 
> Well, no. Do the FOX examples work (i.e. those that came with the C++ library)?

Sorry for the late reply.  Was busy with something else.

No, they don't.  This is a FOX issue.

It happens as soon as Fox is compiled with:
--with-xim
Without that, all text widgets work fine.

This is fox1.6.23, and latest fxruby, running under Linux (latest
Ubuntu).  Probably not a bug but a configuration issue on my part.  Not
clear what that option does.


-- 
Gonzalo Garramuño
ggarra at advancedsl.com.ar

AMD4400 - ASUS48N-E
GeForce7300GT
Kubuntu Edgy


More information about the fxruby-users mailing list