[fxruby-users] FreeRIDE - Way too many warnings

Lyle Johnson lyle at knology.net
Sat Jan 20 17:24:54 EST 2007

On Jan 20, 2007, at 4:04 PM, Jonathan Allen wrote:

> Forgive my ignorance, by why is Ruby distributing a nearly 2 year-old
> version?

I'm sorry, let me make a less sarcastic attempt at answering your  

FXRuby 1.2 is still included with the Ruby One-Click Installer for  
Windows because FreeRIDE depends on that version of FXRuby. So if  
that version of FXRuby was not included with the Windows installer,  
FreeRIDE wouldn't work. I believe that FXRuby 1.6 is also included  
with the One-Click Installer, by the way, as an optional feature (but  
I'm not 100% sure about that).

So a better question would be, why hasn't the FreeRIDE project  
updated their code to use a more recent version of FXRuby? And the  
answer is that they have very few people working on the project at  
any one time, and no one has really led the charge to make this  
happen. If I recall correctly, FreeRIDE was updated to some extent to  
work with FXRuby 1.4, but I don't think that version of the code has  
ever been released.

I apologize for my previous, jackass-like answer. I just have to  
answer these kinds of questions a lot and there's not much I can do  
to fix the underlying problem(s).

More information about the fxruby-users mailing list