[fxruby-users] FreeRIDE - Way too many warnings

Jonathan Allen grauenwolf at gmail.com
Sat Jan 20 17:04:26 EST 2007


Forgive my ignorance, by why is Ruby distributing a nearly 2 year-old
version?

Jonathan

-----Original Message-----
From: fxruby-users-bounces at rubyforge.org
[mailto:fxruby-users-bounces at rubyforge.org] On Behalf Of Lyle Johnson
Sent: Saturday, January 20, 2007 1:39 PM
To: fxruby-users at rubyforge.org
Subject: Re: [fxruby-users] FreeRIDE - Way too many warnings


On Jan 20, 2007, at 3:28 PM, Jonathan Allen wrote:

> Whenever I start FreeRIDE I get a ton of warnings. It takes a long  
> time
> to start as well, probably because it is I/O bound to the console
> window.

This bug was introduced in Ruby 1.8.5 and it's unclear whether it  
will be fixed. I added a workaround for this Ruby bug in FXRuby  
1.6.4. FXRuby 1.2 is two generations "old" and is no longer being  
maintained by me.

One option is to just ignore the warnings. Another is to downgrade to  
Ruby 1.8.4, which did not have this problem. Yet another is to  
convince the FreeRIDE project to update FreeRIDE for compatibility  
with FXRuby 1.6.
_______________________________________________
fxruby-users mailing list
fxruby-users at rubyforge.org
http://rubyforge.org/mailman/listinfo/fxruby-users



More information about the fxruby-users mailing list