[fxruby-users] Problem using foxGUIb

Lyle Johnson lyle.johnson at gmail.com
Tue Feb 20 14:21:23 EST 2007


On 2/20/07, Ernest Ellingson <erne at powernav.com> wrote:

> I'm not sure what is installed on a linux box when you install the
> fxruby gem.

When you install the fxruby gem on Linux (or any other non-Windows
platform), it will first compile the FXRuby extension source code, and
this may take several minutes. Then it will install that code to your
/usr/lib/ruby/1.8/gems/whatever directory as usual.

> Although looking at the size of the gem file, there must be a precompiled version
> of Fox included in that gem.

No. We only provide precompiled versions of FOX and FXRuby in the
FXRuby gem for Windows. So there are two gems: the "binary" gem for
Win32, which is a pretty quick install (because everything's already
compiled), and the "source" gem for any other platform, which compiles
FXRuby as it installs.


More information about the fxruby-users mailing list