[fxruby-users] Problem using foxGUIb

Alan Lake alan.lake at lakeinfoworks.com
Mon Feb 19 18:23:00 EST 2007

I, too, installed fxruby as a gem on a 64-bit machine running Fedora 
Core 6.  I have not yet been able to run Fox with Ruby and get the same 
error message.  Following Ernie's lead, I modified foxGUIb.rb, adding
    require "rubygems"
just before
    require "version"
It appears that I crashing on the first code in this file
      require FOXGUIB_LIBRARY
    rescue LoadError
      puts "please install libGUIb!!"
      puts $!
I don't know enough about this code to know what FOXGUIB_LIBRARY 
contains, or what it's supposed to contain, but I do know that I have a 
successful install of the library.

Can someone advise me of the next step in resolving this problem?  Thanks.

Ernest Ellingson wrote:
> Meinrad Recheis wrote:
>> On 2/19/07, Ernest Ellingson <erne at powernav.com> wrote:
>>> I'm at a definite loss here.  I downloaded foxGUIb v0.7.  I unzipped the
>>> files.  (Windows XP pro)
>>> I ran ruby install.rb in the libGUIb directory.
>>> I switched to the foxGUIb directory
>>> I tried running foxGUIb_win32.rbw
>>> Nothing happened.
>>> I tried running ruby foxGUIb.rb
>>> I get the following error.
>>> please install libGUIb!!
>>> no such file to load -- fox16
>> all i can say is that libGUIb16.rb is there, gets called and fails in
>> its very first line trying to require fox16. i got no clue about what
>> is going wrong...
>> what happens when you do
>> require "fox16"
>> in irb?
>> what exception stacktrace do you get when you launch libGUIb16.rb directly?
>>> Here is the text in the installed files
>>> C:/ruby/lib/ruby/site_ruby/1.8//libGUIb14.rb
>>> C:/ruby/lib/ruby/site_ruby/1.8//libGUIb16.rb
>>> I have other fox gui's that run fine with require 'fox16'
>>> Anyone have a clue as to what has gone wrong?
>>> Ernie
>> _______________________________________________
>> fxruby-users mailing list
>> fxruby-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/fxruby-users
> Thanks for the response.  I figured out what was going wrong and just 
> now have
> it working.  My fxruby was installed as a gem.  When I upgraded Ruby to 
> 1.8.5
> windows one click installer, It failed to set the Environmental Variable 
> with out that environmental variable, you have to require 'rubygems'.  I 
> haven't tried the
> foxGUI in Linux yet.  However, I know fxruby was installed there as a 
> gem as well.  So
> the foxGUI.rb script will have to have a require 'rubygems" in it in 
> order for it to function
> correctly. 
>      I like the gui though.  It's very handy.  I'm giving a presentation 
> on fxruby to the Atlanta
> Ruby user's group in March.  I will be using the gui to explain how the 
> layout manager works.
> It's also nice to have all the events available for a widget as well.  
> Very nice job.
> Ernie
> _______________________________________________
> fxruby-users mailing list
> fxruby-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/fxruby-users

More information about the fxruby-users mailing list