[fxruby-users] Problem using foxGUIb

Meinrad Recheis meinrad.recheis at gmail.com
Mon Feb 19 14:02:00 EST 2007


On 2/19/07, Ernest Ellingson <erne at powernav.com> wrote:
> I'm at a definite loss here.  I downloaded foxGUIb v0.7.  I unzipped the
> files.  (Windows XP pro)
> I ran ruby install.rb in the libGUIb directory.
> I switched to the foxGUIb directory
> I tried running foxGUIb_win32.rbw
> Nothing happened.
>
> I tried running ruby foxGUIb.rb
> I get the following error.
>
>
> please install libGUIb!!
> no such file to load -- fox16
>
all i can say is that libGUIb16.rb is there, gets called and fails in
its very first line trying to require fox16. i got no clue about what
is going wrong...

what happens when you do

require "fox16"

in irb?
what exception stacktrace do you get when you launch libGUIb16.rb directly?

>
> Here is the text in the installed files
> C:/ruby/lib/ruby/site_ruby/1.8//libGUIb14.rb
> C:/ruby/lib/ruby/site_ruby/1.8//libGUIb16.rb
>
> I have other fox gui's that run fine with require 'fox16'
>
> Anyone have a clue as to what has gone wrong?
>
> Ernie
>


More information about the fxruby-users mailing list