[fxruby-users] FXRuby 1.6.11 problems with Ruby 1.8.5?

Lyle Johnson lyle.johnson at gmail.com
Thu Apr 19 09:48:26 EDT 2007

On 4/19/07, Philippe Lang <philippe.lang at attiksystem.ch> wrote:

> I have just given a try to your new FXRuby release, and I have a few
> problems when my application starts:


> I'm using that Ruby version: ruby 1.8.5 (2006-12-25 patchlevel 12)
> [i386-mswin32]

This bug has been fixed and I can't imagine how it could have snuck
back in. Can you tell me which version of the Ruby One-Click Installer
you're using, specifically?

> Do we need Ruby 1.8.6 maybe? You mention "compatible with the latest
> One-Click Installer for Ruby" in your announce. 1.8.5 is in not the
> latest version, but close!

Well, I *am* compiling everything against the Ruby 1.8.6 include
files, and linking against that version of the Ruby library, so it's
possible that there are some binary incompatibilities with Ruby 1.8.5.
I will try to investigate this later today and see if I can reproduce
the bug.

More information about the fxruby-users mailing list