[fxruby-users] Support for Ruby 1.9?

Lyle Johnson lyle.johnson at gmail.com
Wed Apr 18 08:05:25 EDT 2007

On 4/18/07, Kevin Burge <kevin.burge at systemware.com> wrote:

> As an extension developer myself, I wanted to try to use 1.9 on a
> day-to-day basis before it's released, to make sure that I don't write any
> new incompatible code, and to possibly contribute by reporting bugs to
> various projects that don't seem to be 1.9 compatible sooner rather than
> later.  IMO, it would be nice if, when 1.9 is finally released, there are
> actually libraries that work with it beyond the standard stuff. :)

Sure. ;)

Also, YARV only supports native threads at this point, as far as I can tell.

Native threads, as in operating system threads? Or just the user-space
threads that Ruby 1.8 provides?

Just an update: I checked out the trunk for Ruby 1.9 last night and built
that, but I'm having trouble getting some critical stuff (namely, RubyGems)
to even install. I'm sure this is just a temporary breakage, but it looks
like it's going to be awhile before I can say that FXRuby "works" on Ruby
1.9. Nevertheless, I'll go ahead and apply the patches that you sent (for
FileText.exists?) and so my best to get other things fixed in due time.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/fxruby-users/attachments/20070418/5a822355/attachment.html 

More information about the fxruby-users mailing list