[fxruby-users] Support for Ruby 1.9?

Lyle Johnson lyle.johnson at gmail.com
Tue Apr 17 20:24:06 EDT 2007


On 4/17/07, gga <ggarra at advancedsl.com.ar> wrote:

> As far as I can tell, ruby1.9 has always been functional.  It has
> remained more or less stable since the YARV merge last December.
> There are relatively minor changes to the C api, but nothing earth
> shattering for .so writers.

OK.

> PS.  Talking about SWIG.  As a result of me wrapping FLTK and the Maya
> API library under it, I've submitted 4 patches to the latest SWIG for
> ruby.  Two are for relatively serious bugs in it (that could potentially
> crash it on some rare ocassions).  I'm not sure if Fox could benefit
> from those (Fox mainly uses its own classes and relatively little of the
> features swig).

Yes, the hard parts of FXRuby were completed before SWIG got some of
its more recent useful features (like the director classes support),
and there was some breakage for multiple modules for several releases.
I will probably upgrade to a more recent SWIG at some point, but right
now I'm using a modified version of SWIG 1.3.22.


More information about the fxruby-users mailing list