[fxruby-users] 1.8.6 and kwargs

Lyle Johnson lyle.johnson at gmail.com
Fri Apr 6 23:01:10 EDT 2007


On 4/6/07, Joel VanderWerf <vjoel at path.berkeley.edu> wrote:

> It looks like we still have to require 'fox16/kwargs' or else:
>
> $ ruby dirlist.rb
> dirlist.rb:12:in `initialize': wrong argument type Hash (expected Data)
> (TypeError)
>          from dirlist.rb:12:in `initialize'
>          from dirlist.rb:55:in `new'
>          from dirlist.rb:55:in `run'
>          from dirlist.rb:64
>
> Or did something go wrong in the gem update?

Seems OK here -- what do you get when you type:

    ruby -e "require 'fox16'; puts Fox.fxrubyversion"

?


More information about the fxruby-users mailing list