[fxruby-users] Issue with FXGLViewer

Melton, Ryan rmelton at ball.com
Wed Apr 4 18:31:21 EDT 2007



I'm experiencing a problem with the FXGLViewer class and FXRuby 1.6.7 on
Windows (and all earlier versions of FXRuby 1.6.x).  I have an
application that creates two different FXGLViewers but crashes with a
segfault on the creation of the second FXGLViewer.  The same application
works just fine with FXRuby 1.2.6.  


I was able to recreate the problem using the supplied glviewer.rb
example program by selecting Window->New Viewer several times.  It then
crashes with a segfault at:


glviewer.rb:441: [BUG] Segmentation fault.


I've tried the same test with the C++ version of FOX 1.6.25 and their
glviewer demo does not crash so I believe the issue must be somewhere in


Also tried this with FXRuby 1.6.4 on Solaris and the glviewer.rb doesn't
crash but the following message is printed:


FXRuby.cpp:145:FXASSERT (result==0) failed.


Can anyone else recreate this issue and do you have any hints on
debugging seg faults in ruby?




This message and any enclosures are intended only for the addressee.  Please  
notify the sender by email if you are not the intended recipient.  If you are  
not the intended recipient, you may not use, copy, disclose, or distribute this  
message or its contents or enclosures to any other person and any such actions  
may be unlawful.  Ball reserves the right to monitor and review all messages  
and enclosures sent to or from this email address.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/fxruby-users/attachments/20070404/3091bff1/attachment-0001.html 

More information about the fxruby-users mailing list