[fxruby-users] [ANN] FXRuby-1.4.7 and 1.6.2 Now Available

Lyle Johnson lyle at knology.net
Fri Sep 15 21:39:28 EDT 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

All,

FXRuby versions 1.4.7 and 1.6.2 are now available for download from  
this page:

	http://rubyforge.org/frs/?group_id=300&release_id=6924

Note that you should be using FOX 1.6.5 or later due to some  
important changes made in that release of FOX. Also note that due to  
a bug in RubyGems 0.9.0, building from the source gem isn't advised  
unless you're able to download to an earlier version of RubyGems.  
(This bug doesn't affect binary gems.) And as long as you're noting  
those two things, you should also note that due to a bug introduced  
in Ruby 1.8.5, a large number of warning messages will be printed to  
the console when you load FXRuby (any version) into Ruby 1.8.5. This  
problem is described here:

	http://rubyforge.org/tracker/index.php? 
func=detail&aid=5633&group_id=300&atid=1223

Due to this problem with FXRuby under Ruby 1.8.5, the downloads page  
offers builds for both Ruby versions 1.8.4 and 1.8.5 on Windows.

For a summary of the changes in this release of FXRuby, please see  
this page:

	http://www.fxruby.org/doc/changes.html

As usual, the code is provided as a Win32 installer or a binary Gem  
(both compatible with the latest One-Click Installer for Ruby  
1.8.4/1.8.5), as a source gem, and as a source tarball. For  
instructions on compiling FXRuby from source, please see:

	http://www.fxruby.org/doc/build.html

And as always, the FXRuby home page is here:

	http://www.fxruby.org

Enjoy,

Lyle

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (Darwin)

iD8DBQFFC1XRFXV/hD6oMd0RAj9vAKCJbdiln2DzYYIWf/o79lNKo0deawCfUDEt
rQVY3hbB7Uw46f4NhMCwnRA=
=bb40
-----END PGP SIGNATURE-----


More information about the fxruby-users mailing list