[fxruby-users] ruby-1.8.5 loads fox16.so more than once

Joel VanderWerf vjoel at path.berkeley.edu
Fri Sep 1 14:04:24 EDT 2006

Lyle Johnson wrote:
> On Sep 1, 2006, at 1:48 AM, Joel VanderWerf wrote:
>> Hi, all,
>> After upgrading ruby from 1.8.4 to 1.8.5, loading fox16 causes a  
>> warning
>> for each constant, and $" shows that the .so has been loaded more than
>> once (see below).
>> I remember reporting this long ago for ruby 1.9 [1]. Maybe something
>> from 1.9 has now appeared in 1.8.5 that is causing this problem?
>> Could it be that I just need to rebuild fox16 against the newer ruby?
>> [1] http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/117682
> Well, this is no good. I'm seeing the same problem on Mac OS X with  
> fox16 built against Ruby 1.8.5 -- so I don't have any reason to  
> believe that rebuilding will make the problem go away. And I see that  
> you didn't get any responses to your post to ruby-core (did you?)

I can't seem to find any responses (and I have no clear memory of any).

There doesn't seem to be anything in Mauricio's 1.8.5 writeup[1] that 
would explain the problem.

[1] http://eigenclass.org/hiki.rb?ruby+1.8.5+changelog

> I guess I need to run this under the debugger and see what's going on  
> (i.e. why it's loading the shared object more than once). Surely the  
> semantics of require haven't changed?
> _______________________________________________
> fxruby-users mailing list
> fxruby-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/fxruby-users

       vjoel : Joel VanderWerf : path berkeley edu : 510 665 3407

More information about the fxruby-users mailing list