[fxruby-users] Problems

Steven Quinones-Colon stevenq1967 at gmail.com
Tue Nov 28 18:59:08 EST 2006


KDE version:  3.5.1-0.1.fc4 Red Hat
  System:  Linux
  Release:  2.6.16-1.2069_FC4smp
  Machine:  x86_64
ruby 1.8.5 (2006-08-25) [x86_64-linux]
fox-1.6.20
I installed FOX to  ~/Applications therefore
libFOX-1.6.so is at ~/Applications/lib and
fox-1.6 is at ~/Applications/include
Fox works fine, but...
I installed  fxruby-1.6.3 and when I do: require 'fox16' I get a ton of these:
/usr/people/stevenq/Applications/lib/ruby/site_ruby/1.8/x86_64-linux/fox16.so:
warning: already initialized constant ID_SORT_CASE
/usr/people/stevenq/Applications/lib/ruby/site_ruby/1.8/x86_64-linux/fox16.so:
warning: already initialized constant ID_REFRESH
/usr/people/stevenq/Applications/lib/ruby/site_ruby/1.8/x86_64-linux/fox16.so:
warning: already initialized constant ID_LAST
 and fxRuby seems broken,
Any ideas?
Steven


More information about the fxruby-users mailing list