[fxruby-users] FXPNGIcon.new not working

Ernest Ellingson erne at powernav.com
Mon Nov 20 23:56:58 EST 2006


Hi:
 I am running Ubuntu 6.06 on an AMD64 box.   I'm running Ruby 1.85

I downloaded and compiled and installed Fox-1.6.20.  In the test 
directory I ran several of the test programs successfully.

I used gems to install fxruby-1.6.2
I went to the examples directory and tried running hello.rb.  This 
generated lots of warnings.  I found a solution on the web.  Basically 
it called for removing all the require 'fox16' lines in the programs in 
gem lib directory. I did this and ran hello.rb without warnings.  I then 
tried running iconlist.rb.

The program ran but the folder icons did not display.  Instead of the 
icons there was a box with PNG inside.  I added the following code.

if FXPNGIcon.supported?
 puts "SUPPORTED"
else
 puts "NOT SUPPORTED"
end

The code yielded NOT SUPPORTED

I also tried adding icon.create() before returning icon from the 
loadIcon method.

What am I doing wrong? and How do I fix it?

Thanks,
Ernie


More information about the fxruby-users mailing list