[fxruby-users] Error when compiling FXRuby-1.6.0

Lyle Johnson lyle at knology.net
Tue May 30 10:48:30 EDT 2006


On May 30, 2006, at 4:10 AM, Stephen Ng wrote:

> I tried looking at the Archives and did not find any reference to my
> problem, so I thought I might try asking!
>
> I am trying to compile FXRuby-1.6.0 on my Fedora Core 3 system which 
> has
> ruby 1.8.4 installed. I received the following error -
>
> g++ -fPIC -O0 -g -pipe -m32 -march=i386 -mtune=pentium4 -Wall  -fPIC 
> -O0
> -Iinclude   -I. -I/usr/lib/ruby/1.8/i386-linux
> -I/usr/lib/ruby/1.8/i386-linux
> -I/home/sng/downloads/FXRuby-1.6.0/ext/fox16 -DHAVE_SYS_TIME_H
> -DHAVE_SIGNAL_H -I/usr/local/include/fxscintilla
> -I/usr/local/include/fox-1.6  -c table_wrap.cpp
> table_wrap.cpp: In function `VALUE _wrap_FXTable_onUpdSelectCell(int,
> VALUE*, VALUE)':
> table_wrap.cpp:1280: error: 'class FX::FXTable' has no member named
> 'onUpdSelectCell'

<snip>

I'm not sure what to tell you; this doesn't really make sense. The 
FXTable class definitely has an onUpdSelectCell() member function 
defined in its header file (FXTable.h). Which version of FOX 1.6 do you 
have installed, and where did you get it?



More information about the fxruby-users mailing list