[fxruby-users] wrt FXRuby 1.6.0

Charles D Hixson charleshixsn at earthlink.net
Sun Jun 4 04:15:12 EDT 2006


*>Meinrad Recheis* meinrad.recheis at gmail.com
<mailto:fxruby-users%40rubyforge.org?Subject=%5Bfxruby-users%5D%20%5BANN%5D%20FXRuby%201.6.0%20Now%20Available&In-Reply-To=f2f1845532d23bbd18be714d68691139%40knology.net>
/>Sun Jun 4 02:32:40 EDT 2006/

    * *>Messages sorted by:* [ date ]
      <http://rubyforge.org/pipermail/fxruby-users/2006-June/date.html#877>
      [ thread ]
      <http://rubyforge.org/pipermail/fxruby-users/2006-June/thread.html#877>
      [ subject ]
      <http://rubyforge.org/pipermail/fxruby-users/2006-June/subject.html#877>
      [ author ]
      <http://rubyforge.org/pipermail/fxruby-users/2006-June/author.html#877>


------------------------------------------------------------------------

>On 5/29/06, Lyle Johnson <lyle at knology.net <http://rubyforge.org/mailman/listinfo/fxruby-users>> wrote:
>>/ All,
/>>/
/>>/ FXRuby version 1.6.0 is now available for download from this page:
/>>/
/>>/         http://rubyforge.org/frs/?group_id=300&release_id=5497 <http://rubyforge.org/frs/?group_id=300&release_id=5497>
/>>/
/>
>lyle,
>
>i have a problem installing fxruby 1.6 gem on linux. the fox16.so
>compiled fine. everything seems to be in its place but require "fox16"
>doesn't seem to work.
>
>henon at golem <http://rubyforge.org/mailman/listinfo/fxruby-users>:~$ irb
>irb(main):001:0> require "fox16"
>=> false
>irb(main):002:0> Fox
>NameError: uninitialized constant Fox
>        from (irb):2
>irb(main):003:0> VERSION
>=> "1.8.3"
>irb(main):004:0>

I'm experiencing a closely analogous error on a Debian Etch system.  It doesn't matter whether the file is installed via gem or via compiling the tarball.  The symbol Fox is still undefined.
test.rb:3: uninitialized constant Fox (NameError)

Where does one find the documentation for fox14?  That gem appears to be working flawlessly, (Well, there's a strange error in the unicode example, but perhaps that wasn't expected to work until fox16.), but the only api documentation I've found has been for fox16.





More information about the fxruby-users mailing list