[fxruby-users] fxruby install problem?

Lyle Johnson lyle at knology.net
Wed Jul 12 22:09:48 EDT 2006

On Jul 12, 2006, at 6:59 PM, Hal Fulton wrote:

> OK, that worked. But apparently FreeRIDE needs fox 1.2?

That may be true...

> Here's the tail end of my "gem install fxruby" where I
> tried to get a 1.2 -- what now? (That make.out is empty,
> by the way.)
>  26. fxruby 1.2.1 (ruby)
>  27. fxruby 1.2.1 (mswin32)
>  28. Cancel installation
> > 26
> Building native extensions.  This could take a while...

Do you have FOX 1.2 installed (as well as a version of FXScintilla  
built against that build of FOX 1.2)? Also, note that the latest  
version of FXRuby 1.2 is version 1.2.6; when I tried to install it  
via RubyGems, it came up as option #17 (but I'm not sure how stable  
that ordering is).

As a side note: While I'm sympathetic to the fact that FreeRIDE (and  
perhaps other apps) are still based on FXRuby 1.2, the fact is that  
that version's a couple of "generations" old now. I'm definitely not  
making bug fixes or otherwise developing that series anymore. I'm not  
sure what it would take to get the FreeRIDErs to upgrade to the  
latest FXRuby; I'm guessing that they have just about as much free  
time as I do. ;)

More information about the fxruby-users mailing list