[fxruby-users] require_gem "fxruby"

Meinrad Recheis meinrad.recheis at gmail.com
Wed Feb 15 12:39:13 EST 2006


hi lyle,
a unique way of initializing fxruby would be great.
afaik currently there are 2 methods of require-ing fxruby depending on how
it has been installed.
this is quite inconvenient for application developers who want their app to
run with any fxruby installation type (gem / installer / built from source)

would it be possible to install a "fox14.rb" with fxruby1.4.4 gem that does
the require "rubygems"; require_gem "fxruby"; or something like that.
(i don't know nothing about how rubygems works)
provided that it should be possible to require fxruby144 by calling require
"fox14" also if it was installed as a gem.

best wishes,
-- henon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/fxruby-users/attachments/20060215/afa184aa/attachment.htm


More information about the fxruby-users mailing list