[fxruby-users] Installing RubyFX on MacOS X 10.4.3

Scott Willson scott at butlerpress.com
Mon Nov 21 10:23:11 EST 2005

Here's my experience with Tiger (Mac OS X 10.4.3) on a couple of  
PowerBooks. My skill with C begins and ends with "./configure; make;  
sudo make install" so ....

Fox 1.4.x compiles as-is from source from the command line if you  
have the Apple developer tools installed. The example programs work  
as they should -- if you remember to start your X server first.

On OS X 10.4.2, FXRuby (source or gem) wouldn't compile for me  
without the fixrbconfig gem. I am not sure if this is still necessary  
with 10.4.3, but I suspect so.

With the "fix," FXRuby compiles, but any attempt to use it dies with:
Module() error
Symbol not found in flat namespace

The DarwinPorts FXRuby port _does_ work, but it's at version 1.2. I  
made my own local port, changed all the "1.2"'s to "1.4"'s, and that  
worked, too.

So, what's different in DarwinPorts? Obviously, the link error points  
toward a missing JPEG library, and the only dependencies listed in  
the Portfile are libtiff, libpng, libjpeg, and libX11 for Fox. And  
"otool -L libFOX-1.4.0.dylib" shows the images libs as the only  
difference between working builds.

Long story short, I copied my DarwinPorts versions of libtiff,  
libpng, libjpeg
into /usr/lib on another PowerBook that does not have DarwinPorts nor  
Fink; recompiled Fox and FXRuby from source; and it worked.

I would bet that if OS X users download and compile the "Image  
Formats" libs on the Fox Download page first, we would be able to  
compile and run FXRuby, but I haven't put that to the test.

Hope that helps,

On Nov 20, 2005, at 7:05 PM, Lyle Johnson wrote:

> On Nov 20, 2005, at 8:44 PM, Russell Fulton wrote:
>> Thanks to Lyle I now have everything compiling and installing without
>> obvious errors.  For the archive (if there is one) the problem was  
>> that
>> fink does not have dev versions (i.e. packages that includes the
>> compiler header files) of the many of the libraries.  What I did  
>> in the
>> end was to get the source of the packages from their respective homes
>> and install them from scratch.
> Very curious. I got all of the packages in question from fink and
> managed to get the needed header files. I am still running Mac OS 10.3
> (haven't upgraded to Tiger) and so I don't know if they've changed
> things for the newer fink distributions.
>> Confession time:
>> I did not disable GL in building fox as per instructions (reasoning:
>> the
>> instruction appeared to be quite old -- I know tiger supports GL so I
>> decided to suck and see).
> Yes, OpenGL should work fine. Where did you find a suggestion to build
> FOX without OpenGL support? We need to get that advice out of
> circulation.
>> I also came across stuff on the web suggesting that the apple  
>> supplied
>> ruby was misconfigured and that one had to fiddle with   
>> rbconfig.rb.  I
>> have not done this (on the grounds that one should not fix things  
>> until
>> you are sure they are broken ;)
> Yes, I have also heard this about the Ruby included with Tiger. The
> patch that's out there fixing a problem related to building C
> extensions (like FXRuby) and so I imagine it's worth investigating
> that.
>> When I get his going I volunteer to update the instructions for
>> building
>>   stuff on a tiger using apples Xcode and fink.
> That would be great. I still haven't upgraded to Tiger and don't get a
> lot of feedback from Mac OS X users.
> _______________________________________________
> fxruby-users mailing list
> fxruby-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/fxruby-users

More information about the fxruby-users mailing list