[fxruby-users] Compiling error

Lyle Johnson lyle at knology.net
Wed Nov 16 08:19:54 EST 2005


On Nov 16, 2005, at 2:11 AM, Diego Cano Lagneaux wrote:

> I emerged Fox 1.4.11 with all features turned on recently.
> Since FXRuby 1.4.x is not on Portage, I tried to install 1.4.2 
> manually.
>
> install.rb config works with no problems at all.
>
> install.rb setup aborts with the following output:

<snip>

Diego,

The compilation problem you're seeing is due to an error that was 
present in the FOX header files for FOX versions 1.4.11 and earlier. 
This bug was fixed in FOX version 1.4.12; see:

	http://www.fox-toolkit.com/news3.html

and the release information for FOX 1.4.12 appears about halfway down 
the page. I recommend that you download and install the latest version 
of FOX 1.4 (which is now up to 1.4.24 I believe) and try again.

Hope this helps,

Lyle



More information about the fxruby-users mailing list