[fxruby-users] PNG not working

lyle@knology.net lyle at knology.net
Thu Nov 10 15:23:41 EST 2005

On Thu, 10 Nov 2005 21:12:09 +0100 (MET), "Steven Schmid" <steschmid at gmx.ch>
wrote :

> I recently installed FOX 1.4.23 and FXRuby 1.4.3 and after a few problems
> with the Compiler and some missing libraries, it worked. I can run the
> FXRuby examples, but there's one problem, in the samples where you load a
> png image, theres just a rectangle with the text "PNG" in it. I tried the
> same (imageviewer) example in FOX and it worked. I googled but I couldn't
> find any help, hopefully you can give me a hint? :)

When you build FXRuby, as a last step it links against some FOX library. The
fact that you're seeing the rectangle with "PNG" indicates that FXRuby is
linked against a FOX library that was built *without* PNG support.

If the imageviewer example (for regular FOX) is working, that may indicate
that you have multiple versions of FOX installed and that FXRuby is linked
against some build that didn't have PNG support enabled.

More information about the fxruby-users mailing list